# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^@[^|]*\K\|/ /gm;t' <<< "@ABCD|NN12CT55|GFR
@TEST|TESTTEST|DAT
"