using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^@[^|]*\K\|";
string substitution = @" ";
string input = @"@ABCD|NN12CT55|GFR
@TEST|TESTTEST|DAT
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}