use strict;
my $str = '@ABCD|NN12CT55|GFR
@TEST|TESTTEST|DAT
';
my $regex = qr/^@[^|]*\K\|/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";