#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^@[^|]*\K\|"
Local $sString = "@ABCD|NN12CT55|GFR" & @CRLF & _
"@TEST|TESTTEST|DAT" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)