$re = '/^@[^|]*\K\|/m';
$str = '@ABCD|NN12CT55|GFR
@TEST|TESTTEST|DAT
';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;