#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=http(s)?:\/\/).*"
Local $sString = "http://google.com" & @CRLF & _
"https://www.google.com" & @CRLF & _
"http://abc.cde.google.com" & @CRLF & _
"https://google.co.uk" & @CRLF & _
"http://www.google.co.uk" & @CRLF & _
"https://www.mysite.info" & @CRLF & _
"http://www.mysite.business"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")