using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=http(s)?:\/\/).*";
string input = @"http://google.com
https://www.google.com
http://abc.cde.google.com
https://google.co.uk
http://www.google.co.uk
https://www.mysite.info
http://www.mysite.business";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}