$re = '/(?<=http(s)?:\/\/).*/m';
$str = 'http://google.com
https://www.google.com
http://abc.cde.google.com
https://google.co.uk
http://www.google.co.uk
https://www.mysite.info
http://www.mysite.business';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);