const regex = /(?<=http(s)?:\/\/).*/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=http(s)?:\\\/\\\/).*', 'mg')
const str = `http://google.com
https://www.google.com
http://abc.cde.google.com
https://google.co.uk
http://www.google.co.uk
https://www.mysite.info
http://www.mysite.business`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}