re = /(?<=http(s)?:\/\/).*/m
str = 'http://google.com
https://www.google.com
http://abc.cde.google.com
https://google.co.uk
http://www.google.co.uk
https://www.mysite.info
http://www.mysite.business'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end