import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/^(\\+\\d{1,3}[- ]?)?\\d{10}$/";
final String string = "+1 8087339090\n"
+ "+91 8087339090\n"
+ "+912 8087339090\n"
+ "8087339090\n"
+ "08087339090\n"
+ "+1-8087339090\n"
+ "+91-8087339090\n"
+ "+912-8087339090\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}