re = /\/^(\+\d{1,3}[- ]?)?\d{10}$\//
str = '+1 8087339090
+91 8087339090
+912 8087339090
8087339090
08087339090
+1-8087339090
+91-8087339090
+912-8087339090
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end