$re = '//^(\+\d{1,3}[- ]?)?\d{10}$//';
$str = '+1 8087339090
+91 8087339090
+912 8087339090
8087339090
08087339090
+1-8087339090
+91-8087339090
+912-8087339090
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);