use strict;
my $str = 'Hello, "Joe!"';
my $regex = qr/(?=\W)|(?<=\W)/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";