import re
regex = re.compile(r"(?=\W)|(?<=\W)")
test_str = "Hello, \"Joe!\""
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)