$re = '/(?=\W)|(?<=\W)/';
$str = 'Hello, "Joe!"';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;