const regex = /(foo)(.{5})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(foo)(.{5})', '')
const str = `sdfsdffoocharssdfsdfsdf`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);