use strict;
my $str = 'sdfsdffoocharssdfsdfsdf';
my $regex = qr/(foo)(.{5})/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";