$re = '/(foo)(.{5})/';
$str = 'sdfsdffoocharssdfsdfsdf';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;