#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^/\*\*)|(.*?\*+/$)"
Local $sString = "/**" & @CRLF & _
"* Method1" & @CRLF & _
"* ....." & @CRLF & _
"* @return" & @CRLF & _
"*/" & @CRLF & _
"public int Method1() { } " & @CRLF & _
"" & @CRLF & _
"// this method should be @deprecated" & @CRLF & _
"public void Method2() { } " & @CRLF & _
"" & @CRLF & _
"/**" & @CRLF & _
"* Method3" & @CRLF & _
"* ....." & @CRLF & _
"* @return" & @CRLF & _
"*/" & @CRLF & _
"public int Method3() { }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")