import re
regex = re.compile(r"(^/\*\*)|(.*?\*+/$)", flags=re.MULTILINE)
test_str = ("/**\n"
"* Method1\n"
"* .....\n"
"* @return\n"
"*/\n"
"public int Method1() { } \n\n"
"// this method should be @deprecated\n"
"public void Method2() { } \n\n"
"/**\n"
"* Method3\n"
"* .....\n"
"* @return\n"
"*/\n"
"public int Method3() { }")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")