package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^/\*\*)|(.*?\*+/$)`)
var str = `/**
* Method1
* .....
* @return
*/
public int Method1() { }
// this method should be @deprecated
public void Method2() { }
/**
* Method3
* .....
* @return
*/
public int Method3() { }`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}