using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^/\*\*)|(.*?\*+/$)";
string input = @"/**
* Method1
* .....
* @return
*/
public int Method1() { }
// this method should be @deprecated
public void Method2() { }
/**
* Method3
* .....
* @return
*/
public int Method3() { }";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}