re = /(^\/\*\*)|(.*?\*+\/$)/m
str = '/**
* Method1
* .....
* @return
*/
public int Method1() { }
// this method should be @deprecated
public void Method2() { }
/**
* Method3
* .....
* @return
*/
public int Method3() { }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end