using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=""(?<URL>.+?)"".+?(?<Version>\d{2}\.\d+?\.[\d\w]+?) (?<Type>[\w\s]+?), (?<Date>\w+? \d+, \d+)";
string input = @"<a class=""reference internal"" href=""continuous/dccontinuousseptember2018ooc.html#dccontinuousseptembertwentyeighteenooc""><span class=""std std-ref"">18.011.20063 Out of cycle update, September 19, 2018</span></a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}