$re = '/href="(?<URL>.+?)".+?(?<Version>\d{2}\.\d+?\.[\d\w]+?) (?<Type>[\w\s]+?), (?<Date>\w+? \d+, \d+)/m';
$str = '<a class="reference internal" href="continuous/dccontinuousseptember2018ooc.html#dccontinuousseptembertwentyeighteenooc"><span class="std std-ref">18.011.20063 Out of cycle update, September 19, 2018</span></a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);