// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)href="(?<URL>.+?)".+?(?<Version>\d{2}\.\d+?\.[\d\w]+?) (?<Type>[\w\s]+?), (?<Date>\w+? \d+, \d+)"#).unwrap();
let string = "<a class=\"reference internal\" href=\"continuous/dccontinuousseptember2018ooc.html#dccontinuousseptembertwentyeighteenooc\"><span class=\"std std-ref\">18.011.20063 Out of cycle update, September 19, 2018</span></a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}