import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=\"(?<URL>.+?)\".+?(?<Version>\\d{2}\\.\\d+?\\.[\\d\\w]+?) (?<Type>[\\w\\s]+?), (?<Date>\\w+? \\d+, \\d+)";
final String string = "<a class=\"reference internal\" href=\"continuous/dccontinuousseptember2018ooc.html#dccontinuousseptembertwentyeighteenooc\"><span class=\"std std-ref\">18.011.20063 Out of cycle update, September 19, 2018</span></a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}