const regex = /href="(?<URL>.+?)".+?(?<Version>\d{2}\.\d+?\.[\d\w]+?) (?<Type>[\w\s]+?), (?<Date>\w+? \d+, \d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href="(?<URL>.+?)".+?(?<Version>\\d{2}\\.\\d+?\\.[\\d\\w]+?) (?<Type>[\\w\\s]+?), (?<Date>\\w+? \\d+, \\d+)', 'gm')
const str = `<a class="reference internal" href="continuous/dccontinuousseptember2018ooc.html#dccontinuousseptembertwentyeighteenooc"><span class="std std-ref">18.011.20063 Out of cycle update, September 19, 2018</span></a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}