# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\$`)(.*?)(`\$)/\$$2\$/sgm;t' <<< "p is prime. $`p_i`$ is the $`i^{th}`$ prime.
$`F(p)`$ is the set of factors `f` used to generate multiples of the prime `p`.
$`
\begin{aligned}
\dfrac{5}{2} r \cdot \dfrac{\>\>\>\frac{3}{2} w} {\>1r}
&= \frac{15}{4} w \\
&= \>\>3 \frac{3}{4} \>cups\>water.
\end{aligned}
`$
$`xyz`$
$``$
"