# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\$`)(.*?)(`\$)"
test_str = ("p is prime. $`p_i`$ is the $`i^{th}`$ prime. \n"
"$`F(p)`$ is the set of factors `f` used to generate multiples of the prime `p`.\n\n"
"$`\n"
"\\begin{aligned}\n"
"\\dfrac{5}{2} r \\cdot \\dfrac{\\>\\>\\>\\frac{3}{2} w} {\\>1r} \n"
"&= \\frac{15}{4} w \\\\\n"
"&= \\>\\>3 \\frac{3}{4} \\>cups\\>water.\n"
"\\end{aligned}\n"
"`$\n\n"
"$`xyz`$\n\n"
"$``$\n")
subst = "\\$$2\\$"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.