re = /(\$`)(.*?)(`\$)/m
str = 'p is prime. $`p_i`$ is the $`i^{th}`$ prime.
$`F(p)`$ is the set of factors `f` used to generate multiples of the prime `p`.
$`
\\begin{aligned}
\\dfrac{5}{2} r \\cdot \\dfrac{\\>\\>\\>\\frac{3}{2} w} {\\>1r}
&= \\frac{15}{4} w \\\\
&= \\>\\>3 \\frac{3}{4} \\>cups\\>water.
\\end{aligned}
`$
$`xyz`$
$``$
'
subst = '\\$$2\\$'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result