import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\$`)(.*?)(`\\$)";
final String string = "p is prime. $`p_i`$ is the $`i^{th}`$ prime. \n"
+ "$`F(p)`$ is the set of factors `f` used to generate multiples of the prime `p`.\n\n"
+ "$`\n"
+ "\\begin{aligned}\n"
+ "\\dfrac{5}{2} r \\cdot \\dfrac{\\>\\>\\>\\frac{3}{2} w} {\\>1r} \n"
+ "&= \\frac{15}{4} w \\\\\n"
+ "&= \\>\\>3 \\frac{3}{4} \\>cups\\>water.\n"
+ "\\end{aligned}\n"
+ "`$\n\n"
+ "$`xyz`$\n\n"
+ "$``$\n";
final String subst = "\\$$2\\$";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}