#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(Jahreskontoauszug)(?:.+)((?:19|20)\d{2})(?:.+\s+?)(Pr.miensparen flexibel)\s+?(\d{8,12})"
Local $sString = "8. Januar 2024" & @CRLF & _
"Jahreskontoauszug für den Zeitraum 01.01.2023 - 31.12.2023 Seite 1 von 2" & @CRLF & _
"Pramiensparen flexibel 6353534555" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")