use strict;
my $str = '8. Januar 2024
Jahreskontoauszug für den Zeitraum 01.01.2023 - 31.12.2023 Seite 1 von 2
Pramiensparen flexibel 6353534555
';
my $regex = qr/(?i)(Jahreskontoauszug)(?:.+)((?:19|20)\d{2})(?:.+\s+?)(Pr.miensparen flexibel)\s+?(\d{8,12})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}