$re = '/(?i)(Jahreskontoauszug)(?:.+)((?:19|20)\d{2})(?:.+\s+?)(Pr.miensparen flexibel)\s+?(\d{8,12})/m';
$str = '8. Januar 2024
Jahreskontoauszug für den Zeitraum 01.01.2023 - 31.12.2023 Seite 1 von 2
Pramiensparen flexibel 6353534555
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);