const regex = /(?i)(Jahreskontoauszug)(?:.+)((?:19|20)\d{2})(?:.+\s+?)(Pr.miensparen flexibel)\s+?(\d{8,12})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(Jahreskontoauszug)(?:.+)((?:19|20)\\d{2})(?:.+\\s+?)(Pr.miensparen flexibel)\\s+?(\\d{8,12})', 'gm')
const str = `8. Januar 2024
Jahreskontoauszug für den Zeitraum 01.01.2023 - 31.12.2023 Seite 1 von 2
Pramiensparen flexibel 6353534555
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}