import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(Jahreskontoauszug)(?:.+)((?:19|20)\\d{2})(?:.+\\s+?)(Pr.miensparen flexibel)\\s+?(\\d{8,12})";
final String string = "8. Januar 2024\n"
+ "Jahreskontoauszug für den Zeitraum 01.01.2023 - 31.12.2023 Seite 1 von 2\n"
+ "Pramiensparen flexibel 6353534555\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}