using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s+)*(,)(?:\s+)*";
string substitution = @"\x20$1\x20";
string input = @"ความดี , ความเลว
ตรรกะ,อตรรกะ
ไม่ใช่พวกพ้อง, เป็นพวกพ้อง
รับใช้พลเมือง ,รับใช้หัวหน้าแกงค์
กินอุดมการณ์ , ขายวิญญาณ
เวนเลียงลี ,จินปิงฉี";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}