$re = '/(?:\s+)*(,)(?:\s+)*/u';
$str = 'ความดี , ความเลว
ตรรกะ,อตรรกะ
ไม่ใช่พวกพ้อง, เป็นพวกพ้อง
รับใช้พลเมือง ,รับใช้หัวหน้าแกงค์
กินอุดมการณ์ , ขายวิญญาณ
เวนเลียงลี ,จินปิงฉี';
$subst = "\x20$1\x20";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;