const regex = /(?:\s+)*(,)(?:\s+)*/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s+)*(,)(?:\\s+)*', 'gu')
const str = `ความดี , ความเลว
ตรรกะ,อตรรกะ
ไม่ใช่พวกพ้อง, เป็นพวกพ้อง
รับใช้พลเมือง ,รับใช้หัวหน้าแกงค์
กินอุดมการณ์ , ขายวิญญาณ
เวนเลียงลี ,จินปิงฉี`;
const subst = `\x20$1\x20`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);