import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s+)*(,)(?:\\s+)*";
final String string = "ความดี , ความเลว\n"
+ "ตรรกะ,อตรรกะ\n"
+ "ไม่ใช่พวกพ้อง, เป็นพวกพ้อง\n"
+ "รับใช้พลเมือง ,รับใช้หัวหน้าแกงค์\n"
+ "กินอุดมการณ์ , ขายวิญญาณ\n"
+ "เวนเลียงลี ,จินปิงฉี";
final String subst = "\\x20$1\\x20";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}