# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*>{2,}.*$//gm;t' <<< "Transaction Value >> 100
Transaction Value >>> 100"