using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{1,2}|[a-zA-Z]{2,8})(?:[\/-]{1})(\d{1,2}|[a-zA-Z]{2,8})(?:[\/-]{1})(\d{4})";
string input = @"Today is 6/28/2017 or June/28/2017 or 28/June/2017 or Jun/28/2017 or 28-Jun-2017";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}