$re = '/(\d{1,2}|[a-zA-Z]{2,8})(?:[\/-]{1})(\d{1,2}|[a-zA-Z]{2,8})(?:[\/-]{1})(\d{4})/';
$str = 'Today is 6/28/2017 or June/28/2017 or 28/June/2017 or Jun/28/2017 or 28-Jun-2017';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);