package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{1,2}|[a-zA-Z]{2,8})(?:[\/-]{1})(\d{1,2}|[a-zA-Z]{2,8})(?:[\/-]{1})(\d{4})`)
var str = `Today is 6/28/2017 or June/28/2017 or 28/June/2017 or Jun/28/2017 or 28-Jun-2017`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}