const regex = /(\d{1,2}|[a-zA-Z]{2,8})(?:[\/-]{1})(\d{1,2}|[a-zA-Z]{2,8})(?:[\/-]{1})(\d{4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1,2}|[a-zA-Z]{2,8})(?:[\\\/-]{1})(\\d{1,2}|[a-zA-Z]{2,8})(?:[\\\/-]{1})(\\d{4})', 'g')
const str = `Today is 6/28/2017 or June/28/2017 or 28/June/2017 or Jun/28/2017 or 28-Jun-2017`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}