// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d{1,2}|[a-zA-Z]{2,8})(?:[\/-]{1})(\d{1,2}|[a-zA-Z]{2,8})(?:[\/-]{1})(\d{4})").unwrap();
let string = "Today is 6/28/2017 or June/28/2017 or 28/June/2017 or Jun/28/2017 or 28-Jun-2017";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}