using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<number1>\d{8})_(?<number2>\d{4})";
string input = @"c:\Folder\Nr_11111111_2222.pdf
c:\Folder\Nr_11111111_2222_1.pdf
c:\Folder\Nr_33333333_2222.pdf
c:\Folder\Nr_33333333_2222.pdf
c:\Folder\Nr_44444444_2222.pdf
c:\Folder\Nr_44444444_2222.pdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}