$re = '/(?<number1>\d{8})_(?<number2>\d{4})/m';
$str = 'c:\\Folder\\Nr_11111111_2222.pdf
c:\\Folder\\Nr_11111111_2222_1.pdf
c:\\Folder\\Nr_33333333_2222.pdf
c:\\Folder\\Nr_33333333_2222.pdf
c:\\Folder\\Nr_44444444_2222.pdf
c:\\Folder\\Nr_44444444_2222.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);